Elevated rate of timeouts

Incident Report for ShipEngine

Resolved

This incident has been resolved.
Posted Feb 26, 2026 - 12:02 CST

Monitoring

A fix has been implemented and error rates have begun to drop.
We are monitoring to ensure a complete resolution and are investigating the root cause of this issue.
Posted Feb 26, 2026 - 11:20 CST

Investigating

We are investigating reports of an increased frequency of timeouts and performance degradation impacting some users.
Posted Feb 26, 2026 - 10:26 CST
This incident affected: ShipEngine API.