Elevated rate of timeouts

Incident Report for ShipEngine

Resolved

This incident has been resolved
Posted Apr 21, 2026 - 13:36 CDT

Investigating

We are investigating reports of an increased frequency of timeouts and performance degradation impacting some users.
Posted Apr 20, 2026 - 16:26 CDT
This incident affected: ShipEngine API.