Label Request and Slowness Issues

Incident Report for ShipEngine

Resolved

This incident has been resolved.
Posted Dec 15, 2021 - 11:12 CST

Identified

We have identified an issue with Amazon Web Services which is causing intermittent slowness and issues with label requests. This may affect postage purchasing as well. We are investigating the issue with the proper parties now and hope to clear up any loading speeds as soon as possible. Additional status updates related to AWS can also be followed here - https://status.aws.amazon.com/
Posted Dec 15, 2021 - 10:13 CST
This incident affected: ShipEngine API.