General Performance Degredation

Incident Report for ShipEngine

Resolved

This incident has been resolved.
Posted Sep 09, 2024 - 14:03 CDT

Monitoring

A fix has been released, and we are seeing improved performance. We are continuing to monitor this!
Posted Sep 09, 2024 - 12:45 CDT

Update

The reported errors include "A shipping carrier error occurred: Could not refresh authorization credentials in timely manner." when processing UPS requests, as well as an "Unexpected issue" error on login. We are still investigating this, and we will follow up once there is more information!
Posted Sep 09, 2024 - 11:10 CDT

Investigating

We are aware of technical issues impacting the ShipEngine Platform. We are investigating this, and will provide updates as they become available to us. Thank you for your patience!
Posted Sep 09, 2024 - 10:57 CDT
This incident affected: ShipEngine API, ShipEngine.com (website) and Shipping Carrier Integrations (UPS US).