UPS - Create Label Slowness
Incident Report for ShipEngine
Resolved
This incident has been resolved.
Posted Jun 05, 2023 - 12:47 CDT
Investigating
We are currently seeing intermittent slowness when creating labels through UPS. Our engineering team is currently investigating. We are monitoring and will provide an update when it is available.
Posted Jun 05, 2023 - 12:12 CDT
This incident affected: Shipping Carrier Integrations (UPS US).