FedEx International Priority Service Issue
Incident Report for ShipEngine
Resolved
This incident has been resolved.
Posted Apr 07, 2022 - 15:05 CDT
Update
This incident has been resolved.
Posted Apr 07, 2022 - 15:05 CDT
Identified
We have identified an issue preventing the creation of FedEx International Priority labels. Our engineering team is working to correct the problem.
Posted Apr 07, 2022 - 09:39 CDT
This incident affected: Shipping Carrier Integrations (FedEx CA, FedEx US).